#395 closed defect (fixed)

Crash: NullPointerException in ViewPostFragment

Reported by: mrroundhill Owned by: mrroundhill
Priority: major Milestone: Future Release
Component: posts Version:
Keywords: Cc:

Description

Crash in ViewPostFragment:

java.lang.RuntimeException: Unable to resume activity {org.wordpress.android/org.wordpress.android.Posts}: java.lang.NullPointerException
at android.app.ActivityThread.performResumeActivity(ActivityThread.java:2812)
at android.app.ActivityThread.handleResumeActivity(ActivityThread.java:2851)
at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1287)
at android.os.Handler.dispatchMessage(Handler.java:99)
at android.os.Looper.loop(Looper.java:154)
at android.app.ActivityThread.main(ActivityThread.java:4944)
at java.lang.reflect.Method.invokeNative(Native Method)
at java.lang.reflect.Method.invoke(Method.java:511)
at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
at dalvik.system.NativeStart.main(Native Method)
Caused by: java.lang.NullPointerException
at org.wordpress.android.ViewPostFragment.loadPost(ViewPostFragment.java:130)
at org.wordpress.android.ViewPostFragment.onResume(ViewPostFragment.java:36)
at android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:918)
at android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:1083)
at android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:1065)
at android.support.v4.app.FragmentManagerImpl.dispatchResume(FragmentManager.java:1854)
at android.support.v4.app.FragmentActivity.onResumeFragments(FragmentActivity.java:431)
at android.support.v4.app.FragmentActivity.onPostResume(FragmentActivity.java:420)
at android.app.Activity.performResume(Activity.java:4626)
at android.app.ActivityThread.performResumeActivity(ActivityThread.java:2796)
... 10 more

User messages:

"canceled editing a post"
"I had just published a post that had previously been private and was trying to apply a password to it when it crashed."
"As I was trying to exit the "edit post" menu that came up when I tried to edit "Hello world!", the app froze and then crashed."

Change History (4)

comment:1 Changed 20 months ago by aerych

  • Resolution set to fixed
  • Status changed from new to closed

(In [867]) Fixes #395. Catch general exceptions to handle fringe case errors. In this case rely on fallbacks for linking up stats with the correct blog.

comment:2 Changed 20 months ago by aerych

  • Resolution fixed deleted
  • Status changed from closed to reopened

Wrong ticket.

comment:3 Changed 20 months ago by mrroundhill

  • Owner set to mrroundhill
  • Status changed from reopened to accepted

comment:4 Changed 20 months ago by mrroundhill

  • Resolution set to fixed
  • Status changed from accepted to closed

(In [870]) Should fix crash in ViewPostFragment although I couldn't reproduce to find the actual cause. Fixes #395

Note: See TracTickets for help on using tickets.