Opened 2 years ago

Closed 2 years ago

#394 closed defect (fixed)

Crash in ViewWebStats.java

Reported by: mrroundhill Owned by: aerych
Priority: major Milestone: Future Release
Component: stats Version:
Keywords: Cc:

Description

Received 9 crash reports for this guy:

java.lang.RuntimeException: An error occured while executing doInBackground()
at android.os.AsyncTask$3.done(AsyncTask.java:299)
at java.util.concurrent.FutureTask.finishCompletion(FutureTask.java:352)
at java.util.concurrent.FutureTask.setException(FutureTask.java:219)
at java.util.concurrent.FutureTask.run(FutureTask.java:239)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1080)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:573)
at java.lang.Thread.run(Thread.java:856)
Caused by: java.lang.ClassCastException: java.lang.String cannot be cast to java.util.HashMap
at org.wordpress.android.ViewWebStats$StatsAPIBlogInfoAsyncTask.doInBackground(ViewWebStats.java:727)
at org.wordpress.android.ViewWebStats$StatsAPIBlogInfoAsyncTask.doInBackground(ViewWebStats.java:1)
at android.os.AsyncTask$2.call(AsyncTask.java:287)
at java.util.concurrent.FutureTask.run(FutureTask.java:234)
... 3 more

Change History (2)

comment:1 Changed 2 years ago by aerych

  • Status changed from new to accepted

comment:2 Changed 2 years ago by aerych

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in [867]

Note: See TracTickets for help on using tickets.